[レシピ008]MAMPをインストールしたい

追加情報

2013/12/22

MAMP 2.2のリリースに伴い、デフォルトのPHPバージョンが5.5.3に変更され、合わせてZend OPcacheがバンドルされると共にデフォルトで有効化されています。

OPcacheはオペコードをキャッシュし、実行速度を高速化するためのものでリリース環境では大変有用です。しかし、トライアンドエラーを繰り返すための開発環境で変更した内容が即時反映されないことには問題があります。設定ファイルの以下の箇所を変更し、MAMPを再起動するとOPcacheを無効化することができます。

設定ファイル:/Applications/MAMP/bin/php/php5.5.3/conf/php.ini

1086行目
[変更前] zend_extension="/Applications/MAMP/bin/php/php5.5.3/lib/php/extensions/no-debug-non-zts-20121212/opcache.so"
[変更後] ;zend_extension="/Applications/MAMP/bin/php/php5.5.3/lib/php/extensions/no-debug-non-zts-20121212/opcache.so"